文档管理中心
工具DevEco Studio编写与调试应用附录日志收集和诊断数据

日志收集和诊断数据

若开发过程中遇到DevEco Studio卡顿、卡死或其他故障时,可通过如下两种方式回传日志信息,帮助DevEco Studio提升稳定性体验。

说明

该功能仅支持中国境内(香港特别行政区、澳门特别行政区、中国台湾除外)。

方式一

可点击DevEco Studio Error问题弹窗中的Send Report,点击OK后向DevEco Studio回传日志信息。

方式二

  1. 开发者需要开启数据采集功能,请在File > Settings(macOS为DevEco Studio > Preferences/Settings> Appearance & Behavior > System Settings > Data Sharing设置界面,勾选Send usage statistics

  2. 回传DevEco Studio日志信息。

    • 26.0.0及以上版本
      1. 点击菜单栏Help > Collect Logs and Diagnostic Data或点击工具窗口右侧的Feedback按钮。

      2. Problem Description中填写问题描述,点击Add可上传图片或视频文件,点击View Details查看和选择要上传的.log文件。若需上传日志文件,请勾选Upload DevEco Studio Logs。点击Submit,向DevEco Studio回传日志信息。

        说明

        附件和日志文件最大支持上传500MB的文件,且附件仅支持上传图片或视频文件。

    • 26.0.0以下版本
      1. 点击菜单栏Help > Collect Logs and Diagnostic Data。

      2. 选择.log文件后,点击OK向DevEco Studio回传日志信息。