目录

下载与安装DevEco Studio

下载软件

请前往下载中心,登录华为账号后下载DevEco Studio,并根据下载中心页面工具完整性指导进行完整性校验。

DevEco Studio支持Windows和macOS系统,下面将针对两种操作系统的软件安装方式分别进行介绍。

Windows环境

[h2]运行环境要求

为保证DevEco Studio正常运行,建议电脑配置满足如下要求:

[h2]安装DevEco Studio

  1. 下载完成后,双击下载的“deveco-studio-xxxx.exe”,进入DevEco Studio安装向导。在如下界面选择安装路径,默认安装于C:\Program Files路径下,也可以单击浏览(B)...指定其他安装路径,然后单击下一步。

  2. 在如下安装选项界面勾选DevEco Studio后,单击下一步,直至安装完成。

  3. 单击Finish完成安装。安装完成后,如有需要请根据配置代理,检查和配置开发环境。

    • DevEco Studio提供开箱即用的开发体验,将HarmonyOS SDK、Node.js、Hvigor、OHPM、模拟器平台等进行合一打包,简化DevEco Studio安装配置流程。
    • HarmonyOS SDK已嵌入DevEco Studio中,无需额外下载配置。HarmonyOS SDK可以在DevEco Studio安装位置下DevEco Studio\sdk目录中查看。如需进行OpenHarmony应用开发,可通过File > Settings > OpenHarmony SDK页签下载OpenHarmony SDK。
    • 首次运行DevEco Studio时,若出现Import DevEco Studio Settings弹窗,请选择Do not import settings后单击OK。

macOS环境

[h2]运行环境要求

为保证DevEco Studio正常运行,建议电脑配置满足如下要求:

[h2]安装DevEco Studio

  1. 在安装界面中,将“DevEco-Studio.app”拖拽到“Applications”中,等待安装完成。

  2. 安装完成后,如有需要请根据配置代理,检查和配置开发环境。

    • DevEco Studio提供开箱即用的开发体验,将HarmonyOS SDK、Node.js、Hvigor、OHPM、模拟器平台等进行合一打包,简化DevEco Studio安装配置流程。
    • HarmonyOS SDK已嵌入DevEco Studio中,无需额外下载配置。HarmonyOS SDK可以在DevEco Studio安装位置下DevEco Studio\sdk目录中查看。如需进行OpenHarmony应用开发,可通过DevEco Studio > Preferences/Settings > OpenHarmony SDK页签下载OpenHarmony SDK。

诊断开发环境

DevEco Studio提供开发环境诊断功能,帮助您检查开发环境是否完备。您可以在欢迎页面单击Diagnose进行诊断。如果您已经打开了工程开发界面,也可以在菜单栏单击Help > Diagnostic Tools > Diagnose Development Environment进行诊断。

DevEco Studio开发环境诊断项包括电脑的配置、网络的连通情况、依赖的工具是否安装等。如果检测结果为未通过,请根据检查项的描述和修复建议进行处理。

启用中文化插件

该功能仅支持中国境内(香港特别行政区、澳门特别行政区、中国台湾除外)。